summaryrefslogtreecommitdiff
path: root/fuzz/Cargo.toml
diff options
context:
space:
mode:
authorSunil Nimmagadda <sunil@nimmagadda.net>2024-01-31 14:39:06 +0530
committerSunil Nimmagadda <sunil@nimmagadda.net>2024-01-31 14:39:06 +0530
commit141fe942b909f48aeaf50668c321336975be0ad7 (patch)
treed0718a24b3261332b580467def94f7b66d5e75a5 /fuzz/Cargo.toml
parentc9b3751f061b340e3e92aecd530dfc9d48f9e2cc (diff)
Fuzz vrrpv2::from_bytes
Diffstat (limited to 'fuzz/Cargo.toml')
-rw-r--r--fuzz/Cargo.toml21
1 files changed, 21 insertions, 0 deletions
diff --git a/fuzz/Cargo.toml b/fuzz/Cargo.toml
new file mode 100644
index 0000000..524cdd9
--- /dev/null
+++ b/fuzz/Cargo.toml
@@ -0,0 +1,21 @@
+[package]
+name = "vrrpd-fuzz"
+version = "0.0.0"
+publish = false
+edition = "2021"
+
+[package.metadata]
+cargo-fuzz = true
+
+[dependencies]
+libfuzzer-sys = "0.4"
+
+[dependencies.vrrpd]
+path = ".."
+
+[[bin]]
+name = "fuzz_target_vrrpv2"
+path = "fuzz_targets/fuzz_target_vrrpv2.rs"
+test = false
+doc = false
+bench = false