summaryrefslogtreecommitdiff
path: root/Cargo.toml
diff options
context:
space:
mode:
authorSunil Nimmagadda <sunil@nimmagadda.net>2024-01-17 15:23:51 +0530
committerSunil Nimmagadda <sunil@nimmagadda.net>2024-01-17 15:23:51 +0530
commitb8a95026eeabc5acd767dc9940a9cf5aecdeefbe (patch)
tree25fa1a5e38f3954b1fc0b9cc9cbec9649a9fe435 /Cargo.toml
parentd21ab88e43cddad4342f7236094db56d904633a7 (diff)
Replace nom with std::io::Cursor
std::io::Cursor suffices to parse the packet.
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml3
1 files changed, 1 insertions, 2 deletions
diff --git a/Cargo.toml b/Cargo.toml
index 6baadd6..aa32d63 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -4,5 +4,4 @@ version = "0.1.0"
edition = "2021"
[dependencies]
-tokio = { version = "1.22.0", features = ["full"] }
-nom = "7"
+socket2 = { version = "0.5.5", features = ["all"] }