summaryrefslogtreecommitdiff
path: root/Cargo.toml
diff options
context:
space:
mode:
authorSunil Nimmagadda <sunil@nimmagadda.net>2023-01-01 11:59:24 +0530
committerSunil Nimmagadda <sunil@nimmagadda.net>2023-01-01 11:59:24 +0530
commit26b293760b4cdee55ae689a6f719b3f83a0d3cde (patch)
tree05e1e4a0d4cd579ecb6149ec6b3e0ba5a92dd216 /Cargo.toml
parenta9f5db10c9916e2fccb2582ed65299335a5ce469 (diff)
Implement a VRRPv2 packet parser.
Use nom parser combinator crate to parse a VRRPv2 packet. TODO: checksum verification and checksum tests.
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml1
1 files changed, 1 insertions, 0 deletions
diff --git a/Cargo.toml b/Cargo.toml
index b58a36a..e252638 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -7,3 +7,4 @@ edition = "2021"
[dependencies]
tokio = { version = "1.22.0", features = ["full"] }
+nom = "7"